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• Intro Question
• How would you describe your relationship to Excel?

• Download tools from my website
• http://www.thisisrework.com/vrpa/
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• Understand the layout of Excel
• Create & format a spreadsheet to illustrate data effectively
• Build basic formulas 
• Analyze data by using pivot tables and charts

Caveat: I am not an expert, I am a practitioner. Please also share what you know!

Style of workshop is to work together as we go through different features and 
functions. I may get it wrong, too! That’s part of the process. 
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• Spreadsheet application made by Microsoft
• Other alternatives (Pages, Google Sheets, etc.)
• Spreadsheet = Bookkeeping ledger
• Invented in 1979 by Dan Bricklin and Bob Frankston
• Many different versions so we won’t get into specifics, stick with core functionality
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• Common across all Microsoft applications for consistent look and feel; shortcuts to 
all functionality within the application.

• HOME. The HOME tab includes commands for formatting worksheets, cells and 
data and commands for inserting and deleting columns and rows.

• INSERT. Use the INSERT tab to insert tables, illustrations, charts, links, sparklines, 
headers & footers, custom text and symbols, and more.

• PAGE LAYOUT. Use the PAGE LAYOUT tab to change your margins, change the page 
background, change the page orientation, and more.

• Formulas. Use the FORMULAS tab to browse and select formulas and functions, to 
define names, to audit formulas, and more.

• DATA. Use the DATA tab to access external data, to sort & filter, to access data 
tools, to group cells together, to add subtotals, and more.

• REVIEW. Use the REVIEW tab to check spelling, add comments, protect your 
worksheet or workbook, and more.

• VIEW. Use the VIEW tab to change your workbook view, show or hide gridlines, 
headings, the formula bar and the ruler, arrange windows, freeze panes, zoom in 
or out, and more.
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• Rows
• Columns
• Name Box
• Cancel Button
• Enter Button
• Formula Bar
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• Each cell holds one piece of information which can be simple or complex
• Cells hold 3 types of information: text, value, or formula

• Text: combination of letters, numbers, characters. Can’t be sued for 
calculations. Left justified.

• Value: numbers, dates, times. Can be used for calculations. Right justified. 
Negative numbers in parentheses.

• Formula: begins with equal sign. Expression telling Excel to perform a 
calculation.

• PRO TIP: Excel guess at what kind of format you are using. If excel is wrong, 
enter a single quote mark.

• Each Cell has a specific reference made up of the column (letter) and row (number)
• A cell must be active if you want to enter data. The active cell has a thicker darker 

border
• Bottom right corner of the cell selector is marked by a small square, called the fill 

handle
• Change the cell size by changing the column width or row height
• Selecting groups of cells, columns or rows
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Autofill: Use Autofill if you want to copy an existing logical pattern to new cells. This 
works for number series (1,2,3); text (Mon, Tue, Wed); dates; and formulas.

On the Intro tab, select cell A10 and drag it down. This copies down the value of A10.

Now select cells A5:A10 and do the same. It copies down the pattern rather than the 
value of A10. 

PRACTICE: Copy the pattern in column A of the Info tab until you reach 20.
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• Active tab is highlighted
• Tab names can be added
• Create a tab and name it Data

PRACTICE: Add a new tab in the workbook, name it “Data”, and move it to the right 
of the “Intro” tab.
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• Arrow: Select item from Ribbon, scrolling, other commands
• I-Beam: Type text
• White Plus Sign: Moving over surface of worksheet
• Black Plus Sign: Extend or fill from selected cell
• Black Arrow: Select column or row
• Pointing Hand: Hyperlink
• Double Arrow Cross: Change column width or row height
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• To build a spreadsheet, you’ll probably do a mix of writing new content and 
copying/pasting existing data.

• From the Data tab in the Ribbon or from File à Import, import the Data files you 
downloaded

• Use the Text Import Wizard to import the data to cell A1 of the Data tab

PRACTICE: Import Data into the Data tab of the spreadsheet.
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• Text to columns allows you to separate the content of one Excel cell into separate 
columns. 

• This will come in handy when you copy and paste information from an email or 
another source into a spreadsheet, or if you’re pulling it from an existing Excel 
workbook that doesn’t have the columns separated.

• In this instance, we want to separate first from last names
• Insert a column next to Column A
• From Data Ribbon or drop down menu, select Text to Columns and follow the 

prompt

PRACTICE: Split Name in column A into two separate columns for First Name 
(column A) and Last Name (column B). Don’t forget to update the header row.
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Highlight the entire data set.
Hit the “Data” tab.
Click the “Remove Duplicates” button.
Select what columns you want Excel to find duplicates in.
Hit “OK.”

PRACTICE: Remove any duplicates from the table.
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• Click edge of column or row line to drag
• Double click on edge of line to trim columns or rows
• Select all and right click to apply standard size
• To add more than one, select as many rows or columns as you'd like to add and 

then Right Click and add.

PRACTICE: Make the imported data look like a table with header row & filer.
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• By default, text will stay in the size of the row and spill into the next column
• To avoid this, use the Text Wrap Feature
• Merge
• Left / Right / Center Justification

PRACTICE: Resize the column with Notes data to a column width of 30 and wrap the 
text in that column.
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• Bold the Header Row
• Select Table format from Home Menu
• Add an Auto Filter by going to Data > Filter
• Autofilter allows you to add a filtered drop-down menu to any column of 

information. This is great for finding information quickly.
• Advanced Filter lets you do a bit more using more complex criteria. One Awesome 

Thing you can do with Advanced Filter is get a list of only the unique records in a 
data set that has a bunch of repeated data.

• Sort Data
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• Conditional Formatting applies a rule for data meeting certain criteria to appear 
differently. 

• For example, you could have any cell in a spreadsheet that is negative appear as 
red, and any positive number appear in green.

• In our example, let’s use it to identify which of our campers are under the age of 
18.

• Select column C
• From Home Ribbon or Format menu, select Conditional Formatting
• Format cells that only contain cell value less than 18

PRACTICE: Turn Age data red in column C for all ages under 18.
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• Choose font and font color of your choice
• Use Cell Styles menu
• Use Format Menu
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• View Ribbon or Preferences to turn gridlines on or off
• Use border drop down on Home Ribbon to play with different kinds of lines around 

the cells
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• Data Validation is a rule you can place on an area of cells to make sure they are 
being entered properly. 

• For example, if you want to make sure that the only dates entered in your 
spreadsheets are between specific dates, you could use data validation to prompt 
an error alert when somebody enters a date that doesn’t meet the criteria.

• It also helps you prevent errors in data entry
• Let’s use it to make sure our dietary preferences are limited to a certain list to 

make the food order more streamlined.
• When you go to the Dietary Preferences column and click on the Auto-Filter, what 

do you notice? There are typos and inconsistency in data. This can be really 
problematic if we start building formulas that relies on the data appearing just one 
way; a formula or pivot table could miss information if it’s entered in multiple 
formats.

• Let’s start by creating a simplified list of diets based on the data provided.
• Select Column H and go to Data > Advanced Filter
• Choose to copy the data to another location and to copy unique records only.
• Correct the errors so there is just one type of each preference and reorder the list 

into ABC order.
• Select Column H again and go to Data > Validation
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• In the Validation Criteria, select the List and identify the source as column O
• Create an Input Message and Error Alert

PRACTICE: Create a data validation rule to standardize Diet Preference in column H 
by creating an alphabetized drop down menu in column O. Hide Column O.
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• Freeze Panes holds columns and/or rows in place so that you can scroll through 
information

• From the View Ribbon or Window drop down
• Select the cell that is to the right of the column you want to freeze and 

underneath the row you want to freeze.
• In the Window menu, select Freeze Panes.

PRACTICE: Freeze panes for the first 2 columns and header row.
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• Right click on any cell and get the Format Cell window
• Or from Format menu

PRACTICE: Reformat Fee data in columns D&E to Accounting format.
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• If you want to make sure your awesome spreadsheet doesn’t get hijacked, 
protect the sheet. 

• This works particularly well if you’re using your sheet as a data entry form 
for other people to use. 

• You can protect the cells that are not to be filled in (formulas, row headers, 
etc.) and not protect the cells that people will enter data into.

PRACTICE: Protect the worksheet and the workbook.
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• Formulas can either be used like math equations or one of many Excel-specific 
functions. 

• You can type in the values you want to use, or you can move your cursor to the 
cells you wish to include anywhere within the workbook.
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• Formulas can either be used like math equations or one of many Excel-specific 
functions. 

• You can type in the values you want to use, or you can move your cursor to the 
cells you wish to include anywhere within the workbook.

• Formulas always begin with an =
• We’re going to look at 6 kinds of formulas
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• Nesting allows you to tell Excel how a formula should be completed…. The order of 
operations.

• Nested parenthesis will change colors to help you keep track.
• Use of parentheses can not only help you avoid calculation errors but also help you 

better understand what the formula is doing.
• Every open parenthesis must have a matching close parenthesis. 
• You can imagine that when you start adding lots of parentheses to your formula, 

determining which open parenthesis has a matching close parenthesis can get 
difficult

• Excel offers some help by color coding the parentheses while you’re in Edit mode. 
• Matching open and close parentheses will have the same color.
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• Cells have either an “absolute” reference or a “relative” reference. By default, cells 
use a relative reference, so that as you add information to a sheet or copy 
formulas, the functions move along with the data. However, if you want a formula 
to reference a specific cell even when you copy that reference down, you want an 
absolute reference.

• Relative: Default
• Absolute: Add a $ in front of either or both the column ID and Row ID

• Sheet References: Formulas can reference cells within the same sheet or in other 
sheets in a workbook. When a formula references a cell on its same sheet, the 
name of the sheet is not used. When a formula is referencing a cell in a different 
sheet, it includes the name of the sheet before the cell address in the formula.

• Step 1: Start building the formula you want to build
• Step 2: To reference a cell in another sheet, either click over to that sheet & 

cell or type the location as “Name of Sheet” + “!” + “Cell Address/Name”.
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PRACTICE: Find out the total outstanding fee for each camper on the Data tab by 
subtracting the fee in column E from the amount paid in column E by in a new 
column (column G) and then add the range of the new column to determine the 
total amount you need to collect on the data tab. Update the header.
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• Select a cell next to the numbers you want to sum, click AutoSum on the 
Home tab, press Enter, and you're done. When you 
click AutoSum, Excel automatically enters a formula (that uses 
the SUM function) to sum the numbers.
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PRACTICE:
Create a unique ID for each camper in a new column (column A) by combining the 
first initial from first name (column B) and the first 3 initials from last name 
(column C). Update the header.

=UPPER(LEFT(B2,3)&LEFT(C2,1))

Create nametag text for each camper in the furthest row (column L) including first 
name, last name, and cabin name, all in upper case. Update the header.

=CONCATENATE(UPPER(B2&" "&C2&" "&E2))
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PRACTICE: Add a formula to the Worksheet tab to add today’s date in cell D3
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PRACTICE:
Count the number of campers using the Age column on the Data tab in cell D4
Sum the amount of Fee Paid and Fees Due from the Data tab in cells D5 & D6
Calculate the average age of the campers in D7
Calculate the median age of the campers in D8
Find the oldest camper in D9 and the youngest camper in D10
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PRACTICE: 
Find the number of campers in each of the cabins in cells D13, D14, D15
Find the total amount of fees to be collected for each cab in cells D16, D17, D18
Identify the number of campers for each dietary preference in cells D21-25
Determine if you need to hire a specialty chef in cell D26 if the number of vegan 
and gluten free campers is more than half of the total number of campers.

=IF(((D24+D21)/D4)<0.5,"NO","YES")

Count the number of arrivals by day and the % of the total campers for D23-36
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PRACTICE: Create formulas to find the name, cabin, and amount owed for any 
Camper ID

=VLOOKUP(G4,Data!A1:L17,2,FALSE)&" "&VLOOKUP(G4,Data!A1:L17,3,FALSE)

=VLOOKUP(G4,Data!A2:L17,5,FALSE)

=VLOOKUP(G4,Data!A1:L17,8,FALSE)
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• If you want to reference something a bit more specific than just the address of a 
cell or a range when building a formula, you can name a cell or a range.

• Highlight the cell or range you wish to name
• Go to the name box and type the name of your choice
• From now on, use that name when building formulas
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• Formulas can either be used like math equations or one of many Excel-specific 
functions. 

• You can type in the values you want to use, or you can move your cursor to the 
cells you wish to include anywhere within the workbook.
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• A sparkline is a tiny chart in a worksheet cell that provides a visual representation 
of data. 

• Use sparklines to show trends in a series of values, such as seasonal increases or 
decreases, economic cycles, or to highlight maximum and minimum values. 

• Position a sparkline near its data for greatest impact.

PRACTICE: Create sparklines in column F to illustrate data trends.
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PRACTICE: Create an in cell bar and dot chart using =REPT to illustrate camper ages.
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• A PivotTable is a powerful tool to calculate, summarize, and analyze data that lets 
you see comparisons, patterns, and trends in your data.

• Pivot tables are a way to select & display certain information from a larger table or 
database. They can also be used as a jumping off point for creating charts. They 
can sort & sum, organize & simplify, data and create a summary of the 
spreadsheet.

• Data types in columns should be the same. For example, you shouldn't mix dates 
and text in the same column.

• PivotTables work on a snapshot of your data, called the cache, so your actual data 
doesn't get altered in any way.

• Select your table data
• Go to Insert Ribbon > Pivot Table
• Play with the arrangement of Filters, Columns, Rows, and Values to see your data 

represented in different ways
• Design your table based on the fields available by dragging fields into the areas 

below:
Filter – Allows you filter the table based on the field you enter.
Column – Add additional categories/criteria of information.
Row – Select the data categories you want.
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Sum Values – Will sum any field of data.

Report Filter: This allows you to only look at certain rows in your dataset. For 
example, if I wanted to create a filter by house, I could choose to only include 
students in Gryffindor instead of all students.
Column Labels: These could be your headers in the dataset.
Row Labels: These could be your rows in the dataset. Both Row and Column labels 
can contain data from your columns (e.g. First Name can be dragged to either the 
Row or Column label -- it just depends on how you want to see the data.)
Value: This section allows you to look at your data differently. Instead of just pulling 
in any numeric value, you can sum, count, average, max, min, count numbers, or do a 
few other manipulations with your data. In fact, by default,when you drag a field to 
Value, it always does a count.

PRACTICE: Create a Pivot Table in a new worksheet to see dietary preference 
totals by cabin.
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Charts are a great and automated way to display data within excel.
Column: Comparison of 1 or more series of data points along 2 
variables, typically time (x-axis) and amount (y axis).
Bar: Column chart on the side. Helpful if you want to emphasize data 
from the x-axis point of view (time).
Line: Great for displaying trends of 1 or many data points.
Area: Similar to Line, but with solid areas. Area Charts can be used to 
plot the change over time and draw attention to the total value across 
a trend. By showing the sum of the plotted values, an area chart also 
shows the relationship of parts to a whole.
Pie: Displays 1 series of data as parts of a whole (pie).
Scatter/Waterfall: Demonstrate how the values to 2 series compare 
over time.
Doughtnut/Treemap: A Doughnut chart shows the relationship of parts 
to a whole. It is similar to a Pie Chart with the only difference that a 
Doughnut Chart can contain more than one data series, whereas, a Pie 
Chart can contain only one data series.
Bubble: A Bubble chart is like a Scatter chart with an additional third 
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column to specify the size of the bubbles it shows to represent the 
data points in the data series.

How Charts Work:
Step 1: Select the area of data you want to visualize (could be a pivot 
table)
Step 2: In the Insert menu, select Charts and choose the type of Chart 
you want
Step 3: Format Chart as desired

PRACTICE: Create a pie chart of Dietary Preferences on the Worksheet Tab. Try 
other charts!
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• Formulas can either be used like math equations or one of many Excel-specific 
functions. 

• You can type in the values you want to use, or you can move your cursor to the 
cells you wish to include anywhere within the workbook.
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